4 posts / 0 new
Last post
halobrace's picture
Victorialand
Oct 2005
6 years ago

I have acquired a couple of Boss DC-2 dimension- c pedals over the years and i have one that seems to distort the signal passed through it almost like it is being overloaded or peaked out if you play too hard through it.

It is a blue label made in japan version and seems in good shape from the outside( no loose inputs or broken buttons, etc.).

I power it on my pedal board and am not playing a high gain signal through it( in fact it does it even with a clean non-distortion signal). It is ok if you play soft/avergae pick strength, but if you dig hard it seeems to do it.

I have tried different power supplies, batteries, different cables, putting it in different places in my signal path, etc. but it still distorts.

I have lots of boss pedals and none of them including my other DC-2 have ever had this problem. Anyone else ever experienced this with a boss pedal, or specificly a DC-2? Any thoughts or suggestions?

Thanks.

Mosquitocoil's picture
Brisbane, Australia
Oct 2003
7 years ago

Knowing what I know about my limited electronics, I might suggest looking at the input cap/s?? I'm not sure what else to suggest, but that might be a good starting point? :rolleyes: Maybe check/replace it/them if they look bad. Maybe same for output caps?

I'm assuming the signal is distorting as the first thing it does as it enters the pedal...like a headroom issue.

Someone enlighten me please. I feel pretty stupid suggesting this, I have no real clue if it's anywhere near being right. Don't quote me, cause if new info comes to light, I'm gonna change this post ;)

In reality though, I guess it could be any number of components in the damn thing...

-Ravi

Ibanez SZ320 | ES-175 Hollowbody copy
Mesa Boogie Single Rectifier + Marshall 1960A
Boss GT-3 in loop (delays and verbs)

Pics of my rig! (UPDATED 9 JUNE 2006!!!)

Mesa Single Recto + more for sale..

Proud member of the MESA family

halobrace's picture
Victorialand
Oct 2005
6 years ago

Originally posted by Mosquitocoil

I'm assuming the signal is distorting as the first thing it does as it enters the pedal...like a headroom issue.

Exactly what it seems like.

Mosquitocoil's picture
Brisbane, Australia
Oct 2003
7 years ago

I've had problems like that with some of my cheaper no-name pedals. Only thing I could do to fix it was just stick them in a looper...til I eventually sold them :(

I really can't be more help than that. Hopefully one of the builders/modders/electronics guru's will see this thread...you don't have a tech or someone you can take it to?

You can even probably take it to an electronics shop, get someone to look at it...I don't know if they'd be much help, but they'd at least be able to look at the components and tell you if something's not working right/is busted.

-Ravi

Ibanez SZ320 | ES-175 Hollowbody copy
Mesa Boogie Single Rectifier + Marshall 1960A
Boss GT-3 in loop (delays and verbs)

Pics of my rig! (UPDATED 9 JUNE 2006!!!)

Mesa Single Recto + more for sale..

Proud member of the MESA family